$re = '/(?s)(\b\w+\b)(?=.*\b\1\b)/';
$str = 'item1 , test, item3 ;
item4,item5;
test , item6;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);