re = /(?s)(\b\w+\b)(?=.*\b\1\b)/
str = 'item1 , test, item3 ;
item4,item5;
test , item6;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end