const regex = /(?:^|\s)\K[+-]?(?:\d+:\d+|\d+(?:[.,]\d{1,3})+|\d+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)\\K[+-]?(?:\\d+:\\d+|\\d+(?:[.,]\\d{1,3})+|\\d+)\\b', 'gm')
const str = `123 text 2030 text 2,5 text 2.000.000 2,000,000 -200 +31600000000. 200. 2.5 200? 1:200 AB1 9HZ 11AZ +123 -123 1 ,,,,1 1,1 1,1,1,1 1.1.1.1.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}