re = /(?:^|\s)\K[+-]?(?:\d+:\d+|\d+(?:[.,]\d{1,3})+|\d+)\b/m
str = '123 text 2030 text 2,5 text 2.000.000 2,000,000 -200 +31600000000. 200. 2.5 200? 1:200 AB1 9HZ 11AZ +123 -123 1 ,,,,1 1,1 1,1,1,1 1.1.1.1.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end