$re = '/^([^\d]*)([\d]*)/';
$str = 'http://localhost:8080/redirectHome?abc=xyz&sortBy=111\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);