re = /^([^\d]*)([\d]*)/
str = 'http://localhost:8080/redirectHome?abc=xyz&sortBy=111\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end