$re = '/\[SomeClass\.(?<msgfield>[^]]+\]?)\]/m';
$str = '[url]/XYZ/[SomeClass.Entity["Id"]]
[url]/XYZ/[SomeClass.EntityId]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);