re = /\[SomeClass\.(?<msgfield>[^]]+\]?)\]/m
str = '[url]/XYZ/[SomeClass.Entity["Id"]]
[url]/XYZ/[SomeClass.EntityId]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end