$re = '/^(?:\d+,\s*){5}((?:\d+,\s*){5})/';
$str = '123, 456, 987, 321, 654, 741, 654, 123, 456, 987, 321, 654';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);