re = /^(?:\d+,\s*){5}((?:\d+,\s*){5})/
str = '123, 456, 987, 321, 654, 741, 654, 123, 456, 987, 321, 654'
# Print the match result
str.match(re) do |match|
puts match.to_s
end