package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bInfo:(.*?)\.(?:Call|Avbl)\b`)
var str = `Info:Somestring-103409115825.Call
Info: BIL*ONL*00003.Avbl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}