// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bInfo:(.*?)\.(?:Call|Avbl)\b").unwrap();
let string = "Info:Somestring-103409115825.Call
Info: BIL*ONL*00003.Avbl";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}