package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.pipe(\s\ScatchError(.*).subscribe(.*)`)
var str = `.pipe(
catchError((err) => {
...
})
)
.subscribe((res) => {
...
});
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}