re = /\.pipe(\s\ScatchError(.*).subscribe(.*)/m
str = '.pipe(
catchError((err) => {
...
})
)
.subscribe((res) => {
...
});
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end