$re = '/^\.pipe\(\n\s*catchError([\w\W]*?\}\))\n\s*\)\s*\.subscribe([\w\W]*?\}\));$/ms';
$str = '.pipe(
catchError((err) => {
...
})
)
.subscribe((res) => {
...
});
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);