re = /^\.pipe\(\n\s*catchError([\w\W]*?\}\))\n\s*\)\s*\.subscribe([\w\W]*?\}\));$/m
str = '.pipe(
catchError((err) => {
...
})
)
.subscribe((res) => {
...
});
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end