import re
regex = re.compile(r"^[ \t]*$", flags=re.MULTILINE)
test_str = ("This is the\n"
"first sentence.\n\n"
"This is a really long sentence\n"
"and it just keeps going across many\n"
"rows there will not necessarily be \n"
"punctuation\n"
"or consistency in word length\n"
"the only difference in ending sentence\n"
"is the next row will be blank\n\n"
"here would be the third sentence\n"
"as \n"
"you see\n"
"the blanks between rows of data \n"
"help define what a sentence is\n\n"
"this would be sentence 4\n"
"i want to pull data\n"
"from text file\n"
"as such (in sentences) \n"
"where sentences are defined with\n"
"blank records in between\n\n"
"this would be sentence 5 since blank row above it\n"
"and continues but ends because blank row(s) below it")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")