using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",\s*(?=[^)^\]]*(?:\(|\[|$))";
string input = @"filters=fuelType=D,make=[BMW,CITROEN,DACIA],price=(0,100)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}