re = /,\s*(?=[^)^\]]*(?:\(|\[|$))/
str = 'filters=fuelType=D,make=[BMW,CITROEN,DACIA],price=(0,100)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end