const regex = /^(?:(?:(?!^) (?:and|or) )?(?:\b[A-Z]|\B\([A-Z](?: (?:and|or) [A-Z])+\)\B)){2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?!^) (?:and|or) )?(?:\\b[A-Z]|\\B\\([A-Z](?: (?:and|or) [A-Z])+\\)\\B)){2,}$', 'gm')
const str = `Valid:
A and B and C and D
(A or B) and C
(A or B or C) and D
(A or B or C or D) and E
A and (B or C) and D
A and (B or C) or (C and D)
A or (B and C)
(A and B) or (C and D)
Invalid:
A and B and C and
(A or B and C
(A or B or C) and D or
(A or B or C or D and E
A and or (B or C) and D
A and (B or (C and D)))
A (B and C)
(A and B) or C and D)
(A and B or C and D)
More Invalid:
A
AB or C
A and
or A and B
A and (A)
(A and B) or`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}