import Foundation
let pattern = #" (?:::f{4,6}:)?(?P<host>\S+) -.* "GET \/w00tw00t.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(e) 89.248.171.2 - - [05/Oct/2014:17:45:54 +0200] "GET /w00tw00t.at.blackhats.romanian.anti-sec:) HTTP/1.1" 403 407 "-" "ZmEu""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}