$re = '/[\'">](?=[^\'">]*ROOT)/m';
$str = '" ? asdasdjkh khdsjkhas What???<!@#%^&*()ROOT"
" ? asdasdjkh \' khdsjkhas What???<!@#%^&*()ROOT"
" ? asdasdjkh > khdsjkhas What???<!@#%^&*()ROOT"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);