re = /['">](?=[^'">]*ROOT)/m
str = '" ? asdasdjkh khdsjkhas What???<!@#%^&*()ROOT"
" ? asdasdjkh \' khdsjkhas What???<!@#%^&*()ROOT"
" ? asdasdjkh > khdsjkhas What???<!@#%^&*()ROOT"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end