$re = '/(?<=\W)test(?=\W)/';
$str = 'this is a test test. How is the testtest going? test.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);