re = /(?<=\W)test(?=\W)/
str = 'this is a test test. How is the testtest going? test.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end