using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(e|d|b)-(heme|gome|jome)-([^\/]+)(?!\/)";
string input = @"/jome/stat/d-heme-sdfsdf/ertert
/jome/stat/d-heme-sdfsdf
/jome/stat/d-gome-sdfsdf/qeqwe";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}