#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "> == Ship to == *\n. (\w+\s\w+)"
Local $sString = "> From: "FastTech" <support@fasttech.com>" & @CRLF & _
">" & @CRLF & _
"> == Ship to ==" & @CRLF & _
"> Example Name" & @CRLF & _
">" & @CRLF & _
"> Shipping via Registered Airmail w/Tracking" & @CRLF & _
">" & @CRLF & _
"> == Shipping ETA ==" & @CRLF & _
">" & @CRLF & _
"> == Items ordered ==" & @CRLF & _
">" & @CRLF & _
"> == Other services ==" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> == Order total ==" & @CRLF & _
"> $2.63" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> Thank you again for choosing FastTech." & @CRLF & _
">" & @CRLF & _
"> Kind regards," & @CRLF & _
">" & @CRLF & _
"> The FastTech Team" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> FastTech - gadget and electronics" & @CRLF & _
"> http://www.fasttech.com" & @CRLF & _
"> support@fasttech.com" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> This email was automatically generated for " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")