# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"> == Ship to == *\n. (\w+\s\w+)"
test_str = ("> From: \"FastTech\" <support@fasttech.com>\n"
">\n"
"> == Ship to ==\n"
"> Example Name\n"
">\n"
"> Shipping via Registered Airmail w/Tracking\n"
">\n"
"> == Shipping ETA ==\n"
">\n"
"> == Items ordered ==\n"
">\n"
"> == Other services ==\n"
">\n"
">\n"
"> == Order total ==\n"
"> $2.63\n"
">\n"
">\n"
">\n"
">\n"
"> Thank you again for choosing FastTech.\n"
">\n"
"> Kind regards,\n"
">\n"
"> The FastTech Team\n"
">\n"
">\n"
"> FastTech - gadget and electronics\n"
"> http://www.fasttech.com\n"
"> support@fasttech.com\n"
">\n"
">\n"
"> This email was automatically generated for \n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.