# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Instr\((?<column>[A-Z0-9_]+), '(?<value>(?:[^']|(''))+)'//gm;t' <<< "((FIELD1_NAME like 'Product%') And (Instr(FIELD1_NAME, 'Product_typ') = 1))"