$re = '/Instr\((?<column>[A-Z0-9_]+), \'(?<value>(?:[^\']|(\'\'))+)\'/m';
$str = '((FIELD1_NAME like \'Product%\') And (Instr(FIELD1_NAME, \'Product_typ\') = 1))';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;