using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$?[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{2})?$";
string input = @"$9.00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}