package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\$?[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{2})?$`)
var str = `$9.00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}