import re
regex = re.compile(r"""
<link\s*(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?rel=['"]?stylesheet)
(?:[^>=]|='(?:[^']|\\')*'|="(?:[^"]|\\")*"|=[^'"][^\s>]*)*\s*>
""", flags=re.DOTALL | re.IGNORECASE | re.VERBOSE)
test_str = ("<link *rel=\"stylesheet\"* />\n"
"<link rel=\"shortcut icon\" href=\"favicon.ico\" />\n"
"<link onmouseover=' rel=\"stylesheet\" ' rel=\"shortcut icon\" href=\"favicon.ico\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")