re = /<link\s*(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?rel=['"]?stylesheet)
(?:[^>=]|='(?:[^']|\\')*'|="(?:[^"]|\\")*"|=[^'"][^\s>]*)*\s*>/ix
str = '<link *rel="stylesheet"* />
<link rel="shortcut icon" href="favicon.ico" />
<link onmouseover=\' rel="stylesheet" \' rel="shortcut icon" href="favicon.ico">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end