const regex = /(?:^|(?<=[^\d]))\d{9}(?:!|(?=[^\d])|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=[^\\d]))\\d{9}(?:!|(?=[^\\d])|$)', 'g')
const str = `123741852
blabla n123456789 bla bla 78 texto...
987654321! texto qualquer 12 blaa
123 bla blum 123741852 bobobl
blablum 12345678901 papumpa...
dsafasdfa123741852!wef fdsafafsdqwefqwewq 123741852`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}