$re = '/(?:^|(?<=[^\d]))\d{9}(?:!|(?=[^\d])|$)/';
$str = '123741852
blabla n123456789 bla bla 78 texto...
987654321! texto qualquer 12 blaa
123 bla blum 123741852 bobobl
blablum 12345678901 papumpa...
dsafasdfa123741852!wef fdsafafsdqwefqwewq 123741852';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);