const regex = /FV \K\d{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('FV \\K\\d{4}', '')
const str = `FV 7017 FOR SOMETHING 1076,33 USD.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}