$re = '/FV \K\d{4}/';
$str = 'FV 7017 FOR SOMETHING 1076,33 USD.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);