using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?(?:php)?
(?:(?!\?>)[\s\S])*
(?:\?>)?";
string input = @"<?php foo(); ?>
<abc>
<? foo(); ?>
<?php
foo();
bar();
?>
foo();
bar();
<? //also short open tag
foo();
bar();
?><?php
foo();
bar();";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}