package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\?(?:php)?
(?:(?!\?>)[\s\S])*
(?:\?>)?`)
var str = ` <?php
echo "This is hilarious ?>";
?>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}