re = /<\?(?:php)?
(?:(?!\?>)[\s\S])*
(?:\?>)?/mx
str = ' <?php
echo "This is hilarious ?>";
?>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end