$re = '/(?<![\w\s])\s*(\({\w+}\))/m';
$str = '({match})
this will = ({match})
this will =({match})
this will a({match})
this should = not ({match})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);