re = /(?<![\w\s])\s*(\({\w+}\))/m
str = '({match})
this will = ({match})
this will =({match})
this will a({match})
this should = not ({match})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end