import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/product/.*/[\\w-]+$";
final String string = "/product/9779/this-is-a-product\n"
+ "/product/27193/this-is-a-product-with-a-query-string?productId=50334&ps=True\n"
+ "/product/281727/this-is-another-product-with-a-really-long-title\n"
+ "/product/979\n"
+ "/product/979/product-12-pump-septic\n"
+ "/product/9790/the-1983-ford-sedan\n"
+ "/product/9791/remington-870-3-express-410-pump-shotgun\n"
+ "/category/2738/this-is-a-category";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}