# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^/product/.*/[\w-]+$"
test_str = ("/product/9779/this-is-a-product\n"
"/product/27193/this-is-a-product-with-a-query-string?productId=50334&ps=True\n"
"/product/281727/this-is-another-product-with-a-really-long-title\n"
"/product/979\n"
"/product/979/product-12-pump-septic\n"
"/product/9790/the-1983-ford-sedan\n"
"/product/9791/remington-870-3-express-410-pump-shotgun\n"
"/category/2738/this-is-a-category")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.