#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\s*(?<text>[^$]+?)\s*\$"
Local $sString = "$Hayden Smith$" & @CRLF & _
"" & @CRLF & _
"$Previous work history: 7" & @CRLF & _
"Communication Skills: 8" & @CRLF & _
"Resilience:7$" & @CRLF & _
"" & @CRLF & _
"$Park Hill Soccer Club Canteen - Park Hill Secondary College- 3 months - Volunteer" & @CRLF & _
"Argo Newsagency - Newspaper deliverer - 8 months$" & @CRLF & _
"" & @CRLF & _
"$Hayden is a reliable and hard-working year 11 student seeking customer service work. He has displayed good communication skills, numeracy skills for cash handling, and strong ability to work in a team. He has gained customer service experience while volunteering at the soccer club canteen, as well as experience in handling cash as a newspaper deliverer. Hayden has also demonstrated leadership skills through his roles as a soccer umpire and assistant coach. In his spare time, he enjoys playing and watching soccer, football, and cricket. $"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")