import re
regex = re.compile(r"\$\s*(?<text>[^$]+?)\s*\$", flags=re.MULTILINE)
test_str = ("$Hayden Smith$\n\n"
"$Previous work history: 7\n"
"Communication Skills: 8\n"
"Resilience:7$\n\n"
"$Park Hill Soccer Club Canteen - Park Hill Secondary College- 3 months - Volunteer\n"
"Argo Newsagency - Newspaper deliverer - 8 months$\n\n"
"$Hayden is a reliable and hard-working year 11 student seeking customer service work. He has displayed good communication skills, numeracy skills for cash handling, and strong ability to work in a team. He has gained customer service experience while volunteering at the soccer club canteen, as well as experience in handling cash as a newspaper deliverer. Hayden has also demonstrated leadership skills through his roles as a soccer umpire and assistant coach. In his spare time, he enjoys playing and watching soccer, football, and cricket. $")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")