$re = '/\d+\s+(?<Data>[^\s]*)\s.*/';
$str = '00006 GLP1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);