import Foundation
let pattern = #".getval{(.*?)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
.img-circle m-b{height:120px; width:105px;}
#upload{display:none}
.getval{
visibility: none;
width:60px;
height:60px;
}
#mce_0{position: relative;}
#mce_1{
position: relative;
visibility: none;
width:60px;
height:60px;
}
#mce_2{position: relative;}
#mce_3{position: relative;}
#mce_4{position: relative;}
null{color: #808000;}
#mce_5{position: relative;}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"vibility:visible;"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}