import re
regex = re.compile(r"\w\(\d")
test_str = ("s(544,\"Ahn'Kahar Blood Hunter's Battlegear\",{50118,50789,50762,50812},4) \n"
"s(-469,\"Ahn'Kahar Blood Hunter'sBattlegear(Lookalike)\",50413,49952,50071,50000},nil)\n"
"s(-470,\"Ahn'Kahar Blood Hunter's Battlegear (Lookalike)\",{51877,51911,51853,51914},nil)\n"
"s(-471,\"Ahn'Kahar Blood Hunter's Battlegear (Lookalike)\",{51002,51566,51325,50789},nil)\n"
"s(-472,\"Ahn'Kahar Blood Hunter's Battlegear (Lookalike)\",{50673,50645,50688,50655,50605,50711},nil) \n"
"s(-545,\"Ahn'Kahar Blood Hunter's Battlegear (Recolor)\",{50979,54577,51151,51153,51914,51935},4) \n"
"s(-546,\"Ahn'Kahar Blood Hunter's Battlegear (Recolor)\",{,51289,50655,50688,50711},4)")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)